Have problem with Fire Emblem games

Hello guys,

I am deeply sorry if I should not make a topic like this, but I have been looking over the internet for months and still can’t play Fire Emblem Fate (and they had Shadow of Valentia).

I have tried every single emulation that I can find in the net, and later builds seem to make the game smoother, especially anime cutscenes.

But when I enter a battle, the game LAG as hell. FPS dropped badly. Everything else is fine, really fine. I swear to God that I have heard that “Hhhhheeeerrrreeeee IIIiii…iiiii…iiii goooooo~~~” too many times that I thought, it was hundred!

Should I need to config the Emulator in some way or, should I make any adjustment to my system?

Please help me, thank you very much!

System Information

  • Operating System: Windows 10 Pro 64 bit
  • CPU: Intel® Core™ i7-6700HQ CPU @ 2.60GHz (8 CPUs)
  • GPU: NVIDIA GeForce GTX 960M
  • Citra Version (found in title bar): Have tried everything
  • Game: Fire Emblem Fate - Special Edtion

Log:
[ 47.539629] HW.GPU video_core\renderer_opengl\gl_shader_gen.cpp:GLShader::AppendSource:64: Unhandled texture type 1

Most likely uses a lot of texture copy like in Awakening. I guess you can play without battle animations until Citra has improved that part.

The log doesn’t matter and one line is not the entire the log.


Citra is currently in very early stages of development. Games usually run less than full-speed even on the best computers. Expect bugs and glitches to appear in most games. Many features for a more stable emulation are still in the works. For any major updates, please visit our Homepage.

I understand the Citra is on its innovative way of completion. Yet, I found videos here and there, playing the game so smoothly.

I have also tried the emulation they used, but it is no use even though I have a better hardware (the only push-back was that I am using a laptop). I am thinking that the emulator didn’t use my NVIDIA Geforce GTX960m and instead, used the add-in HD Graphic 530.

I have been thinking this could be the issue but still, I don’t really know how to change this. Sure, I have tried the NVIDIA control panel too.

And for the full log:

[ 0.000000] Common.Filesystem common\file_util.cpp:FileUtil::IsDirectory:122: stat failed on E:\Games\CITRA/user/: The system cannot find the file specified.

[ 0.004924] Common.Filesystem common\file_util.cpp:FileUtil::CreateFullPath:200: path exists C:\Users\hayam\AppData\Roaming/Citra/config/qt-config.ini
[ 10.642954] HW.GPU video_core\renderer_opengl\gl_shader_gen.cpp:GLShader::AppendSource:64: Unhandled texture type 1
[ 10.644427] HW.GPU video_core\renderer_opengl\gl_shader_gen.cpp:GLShader::AppendSource:64: Unhandled texture type 1
[ 23.271817] HW.GPU video_core\renderer_opengl\gl_shader_gen.cpp:GLShader::AppendSource:64: Unhandled texture type 1
[ 23.272835] HW.GPU video_core\renderer_opengl\gl_shader_gen.cpp:GLShader::AppendSource:64: Unhandled texture type 1
[ 23.396720] HW.GPU video_core\renderer_opengl\gl_shader_gen.cpp:GLShader::AppendSource:64: Unhandled texture type 1

Don’t trust YouTube when it comes to Citra. The footage could be very well sped up.

This is also not a full log, because you probably edited the logging options in the .ini so it would only show the Critical entries.

Try turning off Accurate Hardware Shader. I did it and it runs smoothly with my ryzen 3 1300x and nvidia1030 combo. You can also try to boost your gpu it also increases performance.

Please don’t reply to old topics. This thread was made before all of the hardware shader updates. If you have a issue yourself, please make a new thread.