Help using a mouse


Since I downloaded Citra I’ve been struggling to find a way to use the mouse in the games. I’m already aware that the mouse is supposed to be used on the touch screen, but that simply does not suit me.

I found a very good and well-explained topic about how to use a mouse on Citra.
Here’s the link: How to use a Mouse as a Virtual Joystick in Citra, in order to control a Camera View or for custom Mouse Input

The problem is I did everything as listed, but in the end nothing happens. It doesn’t work. When I press F11 as stated on the guide, it actually makes my cursor disappear, which should happen, but then none of my commands work. Actually, It’s almost like if I had ghost keys assigned to the 3DS buttons.

I’ve also tried:
Opening both the script and Citra as administrators, but it didn’t change anything.
Using a previous version of Citra, but it didn’t work.

Has anyone come accross this problem?
Is there a known fix for that?

System Information

I wished to upload five images but since I’m a new user I was only able to upload three.

Thanks in advance.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Since this is not a citra problem, changing category to General.

remember that this tutorial is old, open citra and reconfigure your joysticks, after open the qt-config file, and the idea of the tutorial is to enumerate the buttons from button_a = ...button=0
to button_home = ...button14, only change the numbers and not the entire line.

Ignore my comment above, i decide to try this tool finally, a much easier way to set up is to install the vjoy, increase the number of buttons as the guide recommends, download and open the mouse2joystick tool, add or remove the keys you want to use on your keyboard in the keylist, keylist reference.

launch citra. now citra will recognize the vjoy virtual joystick and the mouse2joystick will assign the keys in the keylist to the virtual joystick, you can now tell citra which key to use.

since you press F1 to activate, and the mouse disappears, what you can do is to go to Emulation > Configure > Input, left click on the key you want to modify, press F1, and press the key you want. for c-stick, click on ‘Set Analog Stick’, click ok on the message, press F1 to activate the mouse2joystick, move the mouse left, right, up, down.

remember to press F1 again so you can the mouse pointer and click ok.

You’re a genious, I did what you instructed and it worked. Except the analog part, unfortunately. Even though I move my mouse and it seems to aknowledge I did so, it still doesn’t move the camera while I’m playing the game.

I even tried to set them one by one, by clicking on each direction and doing the movement, but it also didn’t work.

Did you have that problem or know a different way to do that?

i first recommended for you to do this way because of the way that citra (sdl actually) will look for the joystick, vjoy creates the virtual interface with a port and guid, if you look at your qt-config you will see something like this, in this case for the button x:

you can copy the necessary part to modify the c-stick:

i actually misread you.

reminder: be sure that you are not confusing c-stick with circle pad, and remember that these are the analogs that the mouse will control, if your game uses the c-stick, remember to enabled it, if it uses other keys, you will need to set the mouse to those keys.

I wasn’t confusing c-stick with the circle pad. The circle pad controls my movements, and I can move just fine. The problem is just the camera, the c-stick, that no matter what I do, won’t work with my mouse.

You mentioned that I have to enable it, right? But how do I know if it’s already enabled or not? And if it isn’t, how do I enable it?

If it helps, you can take a look again at the screenshot I posted on my first message. When I configure, it stays exactly like that:

Axis 0 Axis 0
Axis 1 Axis 1

oh now i see it, i thought you are playing a game that normally uses the c-stick, DQVIII uses the d-pad.
you have two options, either set the mouse to the d-pad keys,or in-game press x to open the menu, go to misc > settings and invert control pad both up/down left/right, this will set the d-pad to the c-stick, however for that to work you will have to enable 3ds mode, so before opening the game, with citra closed, open qt-config file, find the lines:


delete the is_new_3ds\default=false line and set is_new_3ds=true.

Hey brother, that worked.

Thank you so much for your help and support, you really helped me a lot. :grin:

One last thing. I read somewhere that it was possible to assign two different keys to a single action (example: “n” and “m” both perform the action “attack”), but I don’t remember how to do it. Do you know by any chance?

i don’t really understand AHK code, and the code is rather long, ask on the autohotkey forum, link the utility that you are using or the code “mouse2joystick_citra.ahk”, it should be easy enough for experienced ahk coders to help you with that.

Alright. Thanks again, mate. :grin:

Hi, in regard of legend of zelda ocarina of time how do I enable the 3ds mode as I too have this problem with analog stick and I cannot move my camera