Help...wanna multiplay with my sis

Issue:
how can i enter my sis room??
we’re in same house and using same wifi.
i guess i need port forwarding(?), but i don’t know how…
i spent 2 hrs on this…T.T

System Information

  • Operating System: window 7(my sis computer), window 10(mine)
  • CPU: idk
  • GPU: idk
  • Citra Version (found in title bar): citra canary 1492
  • Game: ACNL- Welcome amiibo
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (12.1 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1492 HEAD-33f2c8b
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

You should be able to simply create unlisted room then connect with local IP. You can find what your router assigned your computer with like ipconfig /all in cmd.exe.

my sis created her own room and then i found her room on public room list. i tried to enter, but it showed up like the picture i uploaded. actually i just realized that we’re using different version of citra, so my sister is trying to redownload it with same one.

and it still doesn’t work. hah

aha

If you use the public browser like you’re doing, it will require you to port forward.

May I suggest just using rooms that are already available?

Like @flamesage said, if you want to use the public browser, you’ll need to setup port forwarding.
If you just want to play locally with others on the same router (same Wi-Fi / LAN), you can give your sister your local IP and she can connect to you using “Direct Connection” (Multiplayer > Direct Connect to Room).

To get your local IP Address, find ‘cmd’ in the start menu and in the black window, type ipconfig. Scroll down until you find “IPv4 Address”. It will be something like 192.168.0.100. Using this IP, any person connected to the same router can join your room using the Direct Connection (please note you can’t invite others over the internet to that room unless your router is port forwarded and you give them your public IP, not the local one).

1 Like

Yeah, i even couldnt enter others’ room in public. it just showed up with same problem.

However, in the end, we found the room categorized with any(game), and then we could both enter there. One thing i worry about is that we might not able to find that kind of room in any other days.:sob:

I already tried the method u’ve mentioned. Direct connect still showed me up with same message id got earlier. :cry:

But as i replied to prior answer, the only way i could play with my sis was both entering the room which was categorized into any(game). I don’t know why we couldn’t enter the other rooms categorized into ACNL or pokemon…

Oh wait, when my sis direct connects to me, Do i need to host the room? Actually i did while she connecting me directly and it didn’t work.

We are dealing with same problem currently …