Help With Majora's Mask

Issue:
The game runs great pretty much everywhere except for a few pretty important areas. The fairy fountains and the first boss were a nightmare. Even running at Native resolution I was barely getting 15fps. I’m no emulator expert, but I’m a bit baffled why my PC is having such a tough time with running this game. Now like I said, so far it’s only those two places that are really bad, SO FAR. But I would hate to have every boss fight be this bad.

If I am just SOL on making it run full speed “most” of the time then I find the compatibility list to be HIGHLY misleading. Minor audio glitches sure. But minor graphical glitches is a bit of an understatement. Now I do understand that each person has their own opinion on “playability”, but I still wanted to bring it up.

If anybody has a workaround or a setting that I’m overlooking that would be great! Or if I’m screwed then that’s cool too. I’ll fight through the pain. Keep up the great work! Seriously, it’s pretty amazing what the devs have accomplished so far. :slight_smile:

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel 3770k
  • GPU: MSI GeForce GTX 1070
  • Citra Version (found in title bar): HEAD-f251b88
  • Game: Majora’s Mask 3D
  • Screenshot of Issue (include the full Citra window including titlebar): No screenshot, but I do have a clip from the livestream that I did. https://clips.twitch.tv/StylishCorrectShingleGrammarKing

Citra is still in it’s early days. Most games don’t run at full speed even on the best computers. There’s nothing that you can do right now, you will have to wait.

Also, the compatibility wiki rating is not dependent on the framerate. The game can get “Perfect”, but it could also run pretty badly in terms of FPS.

Hm, we have the same CPU but my GPU is GTX 680, however I can run this game even at 4x res at full speed.

If I have to get 15fps in native, I must down clock to 1.6GHz, are you running at that or? At stock frequency(3.5GHz) you should easily run at full speed in the first boss fight. I get about 25fps in 4x res in that fight though but 30 in native at 3.5GHz. If I overclock to 4.4GHz I get 30fps anywhere at 4x res(right now at least).



Maybe you have vsync on? That usually cuts fps in half if you can’t maintain full speed afaik.

Thanks for the reply!

This is where my confusion comes from lol. I am running the CPU at stock clock. Seems to stick around 3710 MHz and goes up to 3800 every now and then. Every once in awhile when not much is going on the clock speed will drop to 1600 on a core or two, but it is only for a split second. I haven’t messed with clock speeds too much on this because I didn’t do too hot in the Silicon Lottery. But even at my current speed I’m still not understanding my results. Vsync is off. If you have any ideas, I am all ears! Cheers!

4x Resolution

This is Native Resolution. Had to add this picture to a separate post. Still not full speed.

Test with the latest nightly, the mingw build is a bit faster than the msvc build you are using right now.

Just tried the new build in a livestream. Goht was maybe 20 fps or less the whole time at Native res. Ugh…

Just a heads up: upping the internal resolution doesn’t make the game run slower. Citra is mostly dependent on your CPUs single core performance, but the scaled resolution is handled by the GPU.

It does for me in some games actually, but those I play are slow in general. In the case of MM, 25fps at 3.5GHz on 4x res; 30fps at 4.4GHz on 4x res. Probably just bottlenecked by the CPU most likely.

@Ruskie is it still slow even if you don’t stream? If you have the ability to overclock you could try that.