Help with pokémon games freeze

Issue:
Enter a description of your issue here, in full detail.
The emulator simply crashes, the game runs normally, with its problems, but nothing that really makes me wait more than 5 seconds, however it simply freezes the game, it always happens after 30 to 60 minutes of play. I close and open the emulator again, but when loading state, the game goes back to work with many bugs and then crashes again, no matter the point of the game or how many times I repeat the process. it goes back to normal after about 24 hours of waiting, so I can play an hour a day.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-1035G1 CPU @ 1.00GHz
  • GPU: Intel® UHD Graphics 620
  • Citra Version (found in title bar): 1678
  • Game: Pokémon Alpha Sapphire

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt.txt (35.0 KB)

System Information for Support

Client Version                                Nightly 1678 HEAD-e33677b
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            27.20.100.8729
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

no that’s not a problem for me

Update the drivers: https://downloadcenter.intel.com/download/30148/Intel-Graphics-Windows-10-DCH-Drivers

Remember that save states is not a replacement for regular saves, you need to save normally in-game every now and then. You should do a normal save, then load up normally. You can then create new save states from it.

After updating drivers and stop using savestate, I had a great performance and the game worked very well for two hours, so it froze as usual and the same errors occurred again, the game is frozen for no reason, I close the citra , I open it again and it comes back with black pixels flashing across the screen, it works for a few minutes and locks again. I don’t think there is a need to send the log file again because no settings have been changed since the last upload. I saw computers with similar specifications running the games much better, which makes me believe that there is some specific incompatibility with my machine or some configuration difference. do you have any more advice? if possible, I would like to have all possible causes of this bug and tips on how to solve it, so I won’t have to visit the forum every hour

This sounds familiar to this issue:

Try install this:

installed everything, the problem persists

Can you try specifically this? It seems it worked for him:

If that doesn’t work either then I have no idea.

Does the black pixels look identical to the other user?

Upload a new log as well so we can confirm that you have 9168 drivers installed.

can’t upload citra clips