Help with saving game on two different versions of Citra

So this is my issue with my SMT IV saves:

  1. I have a bunch of save states on Citra Nightly 1636 and I want to load a specific save state, go and save my game in game, and then back that save file up from the AppData folder.
  2. I have my main save game files on Citra Nightly 1850, which has my progress that’s much farther ahead than the 1636 save state, and I can back up the save files at will and they work as intended.

The issue I’m running into is that, if I load up the save state I want on Citra Nightly 1636, there are no save files (whether I delete the 1850 files or not), and if I go and save the game and then try to load the game the save I just made is not there. For whatever reason the game is unable to save my game, so the save state I have is stuck in limbo as a save state.

What I’m trying to do is make a game save on that save state so I can save that previous progress and back it up, but it’s not working and instead it just doesn’t save. What can I do to save that save state?

System Information

  • Operating System: Windows 10 64-bit
  • CPU:
  • GPU:
  • Citra Version (found in title bar): 1636 & 1850
  • Game: Shin Megami Tensei IV
  • Screenshot of Issue (include the full Citra window including titlebar):

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

citra_log.txt (39.9 KB)

System Information for Support

Client Version                               Nightly 1636   HEAD-23b6784
Operating System                             Windows 10 (10.0)
CPU                                          12th Gen Intel(R) Core(TM) i7-12700K
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2
GPU Driver Version                           545.92
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

Gonna answer my own question, it seems like the issue is similar to this:

Looking at my log file, I’m noticing that the mount point is showing my laptop’s user folder rather than my current PCs, which might explain why I’m unable to do any saves on the save state.

What I’m gonna try is to transfer the Citra folder and the game rom to my laptop and attempt to make a save there, then bring the save files from the laptop to the main PC and hopefully that works. I will update when I find out if it worked or not

I can safely say that I have the save files now! Glad that I did some research and ran into that post when I did, and actually looked at my log files too, cause otherwise I would’ve just racked my brain against that forever.

Save states also save Citra settings iirc, so it’s possible that after you load the state you need to change the paths as well.

1 Like

Well, turned out that all I had to do was load up my laptop, make in-game saves of the save states, then move the save files to my PC in place of whatever other saves were there, and it worked!

All that being said, how would I go about marking a solution, should I just pick the comment where I answered my own question?