Home menu not working properly

Issue:
Hi Guys, When I try to boot the home menu at the start everything works fine but then when It asks me to go to theme shop to check out new themes, It freezes. I have also tried to see If Citra Canary would fix the problem but It doesnt. I have also tried to press the X button but then it shows an error, how do I fix this?

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i3-6100 3.70 Ghz
  • GPU: Sapphire AMD Radeon RX 460 4GB
  • Citra Version (found in title bar): Latest Nightly Build
  • Game: (Not a game) Home Menu

citra_log.txt (3.1 MB)

System Information for Support

Client Version                                Nightly 1717 HEAD-647a6f8
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon(TM) RX 460 Graphics
GPU Driver Version                            21.7.1 27.20.22017.1004
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

I found no steps in the FAQ

System Information for Support

Client Version                                Nightly 1717 HEAD-647a6f8
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon(TM) RX 460 Graphics
GPU Driver Version                            21.7.1 27.20.22017.1004
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.


They are there ^. Though, keep in mind that the home menu isn’t really supported atm. You can launch the menu itself, but launching anything from the menu doesn’t function.

ok I will try later!

The first method didnt work (The one where I had to delete the config file), and what does the second method mean?

then note the config block number (0xA0001 in the example) and file a bug report

I didn’t try to launch anything I just booted up the menu but It told me to check out the theme shop and If I press the theme shop icon or the X button they both crash so Im stuck…

By the way this is the error log I get with Canary:
citra_log.txt (95.7 KB)
citra_log.txt.old.txt (85.3 KB)

System Information for Support

Client Version                                Canary 1980 HEAD-ffe9bf4
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon(TM) RX 460 Graphics
GPU Driver Version                            21.7.1 27.20.22017.1004
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Nightly 1717 HEAD-647a6f8
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon(TM) RX 460 Graphics
GPU Driver Version                            21.7.1 27.20.22017.1004
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

Not really a method. It just means to file a bug report on Github for your issue.

Can you try to recreate your issue using a portable build? Basically to rule out any issues with your regular Citra installation:
Go to Download Citra - Citra and select Manual download. Then under Nightly Build, click on your operating system’s icon to the right of the latest build available to download the build.
Extract it (.7z can be extracted using Winrar or 7zip) (.tar.gz can be extracted natively on MacOS) and put it where ever you wish. Inside the extracted mingw folder, create a folder called user. This Citra should now store all of its config, save files and such inside of this user folder.
Check to make sure that this user folder is in the same folder that contains citra-qt(.exe)
Now run the citra-qt executable found inside of the mingw folder.