How do I change to a older version of citra canary?

I want to change to canary 520 but I can’t figure it out, can anyone help me? I saw a thread about the same thing I am asking but I don’t really understand it.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Older downloads are stored on the site. Choose manual download, then older versions, on the download page. But why would you want to go so far back? You would suffer a significant degradation of performance that far back.

Sometimes, older builds have some games work or perform better.
Like current Canary build for Smash 3DS makes Battlefield and other stages with many stuff run slow. Even if I disable the shading, it still runs badly.

I’m sticking to the older build because it performs better.