How to increase speed and fps in Citra (specifically 3d Land)

Issue:
When playing Super Mario 3D Land on Citra, the FPS is never at a constant 60, there are some laggy moments and almost constant slowdown of about 1-2%. I can easily run games like Super Mario Galaxy 1 or 2 on Dolphin with barely any slowdown ever, so my hardware is most definitely not the problem.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 3600 6-Core
  • GPU: GeForce FTX 1660
  • Citra Version (found in title bar): Citra Canary 1986
  • Game: Super Mario 3D Land

Diagnostic Log
citra_log.txt (19.1 KB)

System Information for Support

Client Version                                Canary 1986 HEAD-f083b3a
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1660/PCIe/SSE2
GPU Driver Version                            456.71
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

Try settings the CPU Clock Speed to 50% in Emulation>Configuration>System. Keep in mind that underclocking or overclocking may cause freezing to occur. Set it closer to 100% bit by bit if that’s the case until you have a stable underclock. See if that helps with the performance issues.

Changing the CPU Clock Speed didn’t help. There are still a lot of 1-2% slowdown, and even sudden giant increases of FPS for about half a second. There are also still constant audio glitches.

Set it back to 100%. Go to Emulation>Configuration>Audio and turn off Audio Stretching. See if that makes a difference.

1 Like

That actually solved the audio problem. There’s still a really tiny bit of slowdown sometimes, but I can live with that. Thanks!