How to use cirle.pad on Citra?

Try holding D down and hold down the arrow keys in the direction you want to go to in game on your keyboard and it should work.
Update just tryed it and it works

When i press D I stay on the same place, I can’t move doing this
@Takeshineale128

Hold d instead of pressing d + the circle pad buttons (arrow keys)

Still doesn’t work here. I’ve tried hold and press D. And in configurations D button is already set as circle mod. I’m desperate!!!

I have no issues on the latest canary build 1154 on my pc

I’m with this version too, but I’m in linux

I’m using windows 10

I guess linux is the problem. I will play another pokemon game with don’t need to sneak

I’m on mac, after verifying the key of the circle mod, it does not work while I tried both solutions by holding the key and just pressing the key, someone would have a solution?

1 Like

Linux is not the problem, I’m on linux with the latest canary build and I’m able to do it just fine

'Sup folks.
Much love to this thread for giving a newbie the key(no pun intended ;D) to the ORAS sneaking a while ago. Works beautifully (both before and after I reassigned A to the mod key, it’s just more comfortable for me than the default D).

I’m now here for a different reason.
I’ve just started a file in Pokemon Y which has the roller skates, an additional mode of transportation along side the bicycle as the feature that uses the Circle Pad.
They’re obtained in a mandatory event in which a trainer standing in front of the Santaluna gym intercepts the player upon one’s attempt to enter.

My research has shown me that this feature is not too popular and initially, it seems Citra permanently fixes the roller skates to the trainer since it requires both the directional and circle pads to mount and dismount them.
The cause of this misconception is that the default configurations have the arrow keys assigned to the circle pad.
Go into the configuration menu and reassign them to the ‘Directional Pad’ category.
If desired, this can be done via clicking the ‘new’ button to create it as a second configuration set to avoid having to repeatedly reassign them to go between XY and ORAS.

1 Like

worked for me - hold d and use arrow keys

Thank you, too beautiful!

I have the circle pad set to ‘D’ (using keyboard btw). I’ve looked at a lot of citra community posts about this subject and still haven’t found an answer. Can you help me?

I know this is an old thread but its a similar problem.

How do you enable cpad for games that dont enable automatically, such as Metal Gear Solid 3 when you enable it in the options, the game freezes, emulator seems to still be running as i click emulator options ok, just the game hangs.

I have it set to my 2nd stick in the control settings.

Its odd because i can use it in Resident Evil Revelations fine (dont need to enable it)