I can't open any game on citra

Video Core Error. Ensure that you have the latest graphics driver for your GPU:

When I try to open a game the error above appears, but my graphics card is recently installed and already has the latest driver available.

System Information

  • Operation System: Windows 7 64bits
  • CPU: Intel(R) Pentium(R) D CPU 3.00Ghz
  • GPU: NVIDEA GeForce 7600 GT
  • Citra Version (found in title bar): Citra Nightly 903
  • Game: Harvest Moon Skytree Village USA Decrypted

Diagnostic Log
citra_log.txt (6.8 KB)

You’re using a very old version of Citra. Please update to the latest version available: Download Citra - Citra

I tried with a new version of citra like you said but now say this T.T, can it be my graphics card?

this is the log
citra_log (2).txt (4.9 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Ah yep. That GPU is wayyy too old to use for Citra. The lastest OpenGL standard it supports is OpenGL 2.1. Since it was released in 2006, it’s over a decade old at this point. Regardless, I’m pretty sure that even with a OpenGL 3.3 compatible GPU, that CPU of yours wouldn’t run Citra at any playable performance anyways.

In short, it’s time for a new system.

1 Like

Thanxs T.T I’ll try with a better driver to see and if I cant then there´s that.