I can't run Super Mario 3D Land at 100% speed

Hello. I’m new to Citra and I can’t get Super Mario 3D Land to run at 100% speed, even with the graphics settings set at the lowest possible. The game only runs at ≈60% speed in 1-1, dropping as low as ≈40%, which is unplayable. However, in 1-2 (an underground level) the game runs way better (at 90-100% speed). This happens in both Citra Canary and Nightly.

I have tested Mario Kart 7 aswell, which runs better, even reaching 100% speed occasionally, but the speed drops depending on the track, so I can’t run it at a stable 100% speed.

System Information

  • Operating System: Windows 10 Pro 64-bit
  • CPU: Intel Core i3-6100 CPU @ 3.70GHz (4 CPUs)
  • GPU: Nvidia GeForce GTX 750 Ti
  • Citra Version (found in title bar): Citra Canary 2433
  • Game: Super Mario 3D Land
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt.old.txt (23.1 KB)

Go to Emulation>Configuration>Graphics>Advanced Tab and turn on Hardware Shaders.

Okay, this must be magic. Turning Hardware Shader on made the game even slower before but for some reason it can now reach 100% speed, although it drops to 90-95%.