I can't save cheats in Monster Hunter XX

Issue:
I can add cheats and enable cheats with no issue, however, despite having added a txt file with the cheat in the cheats folder I have to manually add it everytime I open citra. I’ve tried deleting the file and adding and saving it from the emulator, but that doesn’t do anything either. If it matters, the cheat is to lock the framerate to 60 FPS, and it functions with no problems.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 7 2700
  • GPU: Nvidia GTX 1050ti
  • Citra Version (found in title bar): Citra Nightly 1697
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<https://community.citracitra_log.txt (4.8 KB) -emu.org/t/how-to-upload-the-log-file/296>

I did not find anything wrong in your log file. Please wait for a moderator to assist.

This seems to be an issue for some users’ AppData folders. You can try extract a manual build (go to the download page then click manual download to get one) and inside its mingw folder, create a new folder called user. This will put Citra in portable mode, meaning you can put this setup anywhere and it will always load saves & settings from this user folder.

You can then copy everything from %appdata%\Citra into this user folder and see if it would let you save the codes. It has worked for others with the same problem.