I can't save in my animal crossing save

Enter a description of your issue here, in full detail.
I recently tried to import my 3ds save data into citra (using JKSM), but I can’t save+leave my game or play with friends. For reason the game says it’s 2034 although it’s 2023 right now, I don’t understand how to fix this
I’d be glad if anyone could help me to correctly import my data into the game, as I really want to play with my save file
Thank you in advance

System Information

  • Operating System: win 10 64bit
  • CPU: i5 10th
  • GPU: GTX 1650
  • Citra Version (found in title bar): the last version
  • Game: Animal crossing
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Please dump your save data using Checkpoint instead.

I tried doing this but it did the exact same thing
Maybe I put my saves into the wrong file, do you know how to access the exact ACNL save file?

Right click on your game in Citra’s game list, then select Open Save Data Location.

Just to check, but could you upload a screenshot of your Emulation>Configuration>System settings?