I can't start almost any of my dumped games on Android Citra but they work perfect on Windows

citra_log.txt (528 Bytes)
citra_log.txt (528 Bytes)

My smartphone is an Redmagic7. Its my first time here on this Forum so i hope my uploaded log will work and solve my issues. I really want to play my dumped games but only Mario 3D Land is working.

The log file is incomplete. Please follow these steps carefully:

  1. Restart the Citra app if it’s already running.
  2. Launch your game and encounter the problem.
  3. Shut down the Citra app (do not restart Citra as that will wipe the log file of important information!).
  4. Navigate to Internal Storage/citra-emu/log and upload the citra_log.txt file in this chat.

Moved the topic from General, to Citra Support.

citra_log.txt (6.1 KB)

Sorry for the late reply. Here is the new log with the steps taken from above.

[ 5.566824] Service.FS <Info> core/file_sys/archive_selfncch.cpp:OpenRomFS:193: Unable to read RomFS
This indicates a corrupted ROM. If the same ROM works fine on desktop, there’s a decent chance that the ROM got corrupted during the transfer from desktop to your Android device. It happens sometimes with large, singular files like that.

I´ve tried it on two other android phones and i got the same result. Do I have to redump these games? Or use another folder (I created one for CIA´s in the citra-emu folder)

Yep. Please refer to our game dumping guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump.