I have a problem with fps

Issue: when I play any game on my emulator the fps go down and it goes very slow, emulator usually runs between 10-20 fps, sometimes goes up dramatically.
I am not sure if it is due to an error in configuration, files or it is only a problem with my pc.

System Information

  • Operating System: windows 10 x64
  • CPU: AMD Ryzen 3 3200u with radeon vega mobile gfx
  • GPU:
  • Citra Version (found in title bar): citra nightly 1695
  • Game: all
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (17.3 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1695 HEAD-c2d36cd
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx  
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) Vega 3 Graphics
GPU Driver Version                            19.40.46 26.20.14046.3
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

how i could fix that?

Update the drivers first: https://www.amd.com/en/support

Then try turn off Hardware Shader in the advanced graphics settings in Citra configuration. If it doesn’t speed it up enough then you would basically need to dual boot Linux (e.g Ubuntu) and get ~3x more performance as there are better drivers for OpenGL there for Radeon.

Other than that you will need a new computer, preferably with Nvidia. Sorry for the inconvenience.

well, I already have my drivers updated.

disable the Hardware Shader and run a little better, lamentably I can’t do a dual boot because this generates a problem on my computer.

and buying a new computer is not possible for me.
thanks all the same.

1 Like

No problem. Yeah another way would be to wait for AMD to improve their drivers for OpenGL on Windows.

If you want you can upload a new log and we could check if they are. The drivers that were reported in your previous log are old; latest would say 21.2.3.

It is also possible to install it to another drive and just change the boot order in BIOS when you plug it in.

oh, i see. I’m not really sure how to check, but I’ll see.

okay, of that if I have no idea how to do it, but I will try to investigate, thanks again.

1 Like