I have no idea how I've managed this to happen

Issue: All settings gone for no reason
All settings, save files, any configurations I had suddenly all gone and I don’t know why. Besides that it runs smoothly and I am infuriated.

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i5-2400 CPU @ 3.10GHz
  • GPU: NVIDIA GeForce GT 1030
  • Citra Version (found in title bar): nightly 1705
  • Game: LBX
  • Screenshot of Issue (include the full Citra window including titlebar): none needed

Diagnostic Log
citra_log.txt (2.9 MB)

System Information for Support

Client Version                                Nightly 1705 HEAD-edbd6df
Operating System                              Windows 10 (10.0)
CPU                                                   Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz | AVX
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GT 1030/PCIe/SSE2
GPU Driver Version                            456.71
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

None of those things are relevant to the issue. Seriously if it were that easy I would have solved this by now.

Did you ever use any sort of portable Citra build before? Or maybe used Save States of any kind?
We recently added the option of changing the location of your nand and sdmc folder (which contain your save files) to the nightly versions, but that shouldn’t have affected your settings configuration.

Never used portable citra, haven’t used saved states yet (do they work because I might use them as an alternitive). I had a thought now that you mention where they are located. I have citra installed outside of the appdata/roaming folder and outside of the programs folder and on a different hard drive. I’m gonna expirement really quick and see if I get my saves back.

Edit: nvm what I tried didn’t help.

Your log file already showed that it was loading Citra’s configuration and save files from the standard position in Appdata. So it shouldn’t have mattered where you installed the Citra executable files itself. Unless you manually cleared the appdata folder, I’m not sure why your configuration and save files are gone.
A portable Citra build would have a folder called user in the same location as the citra-qt.exe file. Citra would store-and-load it’s configuration and save data inside of that user folder if it detects the user folder’s existence in the executable folder. So if you had been using a portable Citra version so far and if that user folder had been deleted somehow, that would explain the loss of data.

Did you perhaps run some sort of anti-clutter program to free up disk space? Such a program might’ve mistakenly flagged the Citra data folder in appdata and wiped it. Other than that, I’m out of ideas.

I do not run any program like that you mentioned. Damn… This is so confusing because ontop of all this I had closed and opened citra and had my save files present multiple times. I will return if I find answers, thank you for your help thus far.