I need the best settings for Citra to work on my pc

Issue:
Enter a description of your issue here, in full detail.
I just need to know what are the best settings I can use for my particular PC, to prevent things such as stuttering, lagging, and transitional errors (In my case the screens freeze mid-transition despite that the game itself is still running as if nothing is wrong, this happened when I was testing out Pokemon Sun and Pokemon Ultra Moon.)

System Information

  • Operating System: Microsoft Windows 10 Home
  • CPU: Intel ® Core™ i5-8300H CPU @ 2.30GHz
  • GPU: I have 2 GPUs
    Intel® UHD Graphics 630
    NVIDIA GeForce GTX 1050 Ti
  • Citra Version (found in title bar): Nightly 1696
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (11.8 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Set your CPU Clock Speed back to 100% in Emulation>Configuration>System.

I also want to make sure that your Citra isn’t running off of your iGPU. For that, you’ll need to generate another log file. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close citra if it doesn’t do so by itself. Do not restart citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.

Just to give you a more accurate look at some of the general problems, I will show you the logs after testing 2 different games and covering their issues.

citra_log.txt (65.5 KB)
This is from testing Pokemon Sun, somewhat close to stable framerate, however going past the title screen and file menu results in a black screen, however I am able to move around and interact with objects and do pretty much everything else, however the audio stutters.

citra_log.txt (219.7 KB)
Lastly here is some gameplay of StarFox 64 3D. There was constant lag, and the one other problem was a visual issue with light reflecting on objects, not to mention the Arwing models were completely blackened aside from the fox symbol and the engine flare, this made flying around look as if I were moving around in pitch black darkness, aside from that the game didn’t slow down to the point of freezing or crashing, I was able to complete the training sequence.

I hope this all helps. I wanted to include some Fire Emblem Fates gamplay logging, but the GPU clock fix seemed to resolve most of the issues, it runs almost completely like normal now.

System Information for Support

Client Version                                Nightly 1696 HEAD-8e3c767
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-8300H CPU @ 2.30GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 630
GPU Driver Version                            23.20.16.5018
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [ ]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.
1 Like

System Information for Support

Client Version                                Nightly 1696 HEAD-8e3c767
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-8300H CPU @ 2.30GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 630
GPU Driver Version                            23.20.16.5018
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [ ]
System Region                                 1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

You are indeed running off of your integrated GPU. You should manually set Citra to run on your GTX 1050 Ti. Close down Citra if you have it open, then right click on your desktop and select NVIDIA Control Panel. Then select Manage 3D settings. Choose Program Settings here and then select citra-qt.exe. It should give you an option to select which GPU to use → Select High performance NVIDIA GPU here or just GTX 1050 Ti (the options aren’t always the same on every PC) and hit Apply in the bottom right corner. Now try Citra again and see if the problems remain. If they do, upload another log file.

Everything started working a whole lot better once I switched the GPU to NVIDIA, thanks for the help!

Just one more question, will doing this manually increase performance with other emulators too? Or is that not necessary if NVIDIA can be accessed via in-program tabs?

If those emulators allow you to select the GPU to use for rendering, then there’s no need to manually set the program to run on NVIDIA specifically. If they don’t allow you to do so, then you should always set them to run on your dedicated NVIDIA GPU manually. Otherwise It’d basically just be free performance you’re leaving on the table xD.

1 Like

Got it, thanks again for the assistance!

2 Likes

not to intervene, but i actually did this on my device to see and citra run on my iGPU as well should i change as well? fyi i use a laptop not a pc

If your laptop has a dedicated GPU in it, then that would almost always be better.

should i do the same for the citra.exe as well (dont even know what that one does over the citra-qt.exe)

citra.exe is simply Citra without a general user interface. However, citra-qt.exe is standalone (meaning you can delete citra.exe and it’ll still work) so you only need to set citra-qt.exe to run on the dedicated GPU.

2 Likes