I recently downloaded citra on my laptop and when i played pokemon X it has no background music. NEED HELP

Issue:
Enter a description of your issue here, in full detail.

System Information

  • Operating System: Window 10 64bit
  • CPU: Intel® Pentium® 3556U @ 1.70Ghz
  • GPU:
  • Citra Version (found in title bar): Citra Nightly 1444
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

i can’t upload my log file, i’m using my phone rn

Can you double check what version of Windows 10 you have? I think this is an issue with the N edition which means you will need to install the Media Feature pack to get the audio codec needed for this game.

Ok upload a log, follow these steps to make sure it catches the issue.

  1. Open Citra then File->Open Citra Folder then log folder(keep this open in the background, do not close the folder).
  2. Start the game, then close Citra after you reach the screen with the issue(don’t reopen or the log gets cleared so you have to do it again).
  3. Reupload the log here.

citra_log.txt (4.8 KB)

System Information for Support

Client Version                                Nightly 1444 HEAD-25ebf03
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hm, it says null. Did you accidentally reopen Citra before uploading the log?

nope, i’ll upload it again

citra_log.txt (5.6 KB)

System Information for Support

Client Version                                Nightly 1444 HEAD-25ebf03
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Weird the log still says you only started Citra and nothing else, and it doesn’t get cut off which is another problem others users get but in that case they would need to turn off Hardware Renderer which will make the game run at 1fps but at least the log would have more info :stuck_out_tongue: Maybe try with that and just close Citra after a few seconds after you have started the game.

how do turn off hardware renderer? sorry i’m still new to this

In the Advanced tab in the graphics options. It is the very first.

after turning it off?

Have the log folder open before you close Citra(so you can access the log file more easily). Start the game, wait a few seconds then close Citra. Then immediately upload citra_log, do not open Citra again until you have uploaded it.

citra_log.txt (20.3 KB)

System Information for Support

Client Version                                Nightly 1444 HEAD-25ebf03
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics
OpenGL Version                                3.3.0
GPU Driver Version                            20.19.15.4531
Enable Hardware Renderer                      [ ]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Audio.DSP <Critical> audio_core/hle/wmf_decoder.cpp:Impl:45: Unable to load mf.dll. AAC audio through media foundation unavailable
Audio.DSP <Warning> audio_core/hle/hle.cpp:Impl:115: Unable to load any decoders, this could cause missing audio in some games

Yeah this is why, I wonder if you can add to “Single Language” Windows 10 even though it is made for N version, give it a try: https://www.microsoft.com/en-us/software-download/mediafeaturepack

On a side note:

Build 20.19.15.4531

These drivers are outdated, you need to update:

Download win64_15.40.44.5107.zip from https://downloadcenter.intel.com/download/29313/Intel-Graphics-Driver-for-Windows-15-40-?product=96743
direct link: https://downloadmirror.intel.com/29313/a08/win64_15.40.44.5107.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

hey it worked but now it’s taking too long to load the game :laughing: and then it became a blank white screen while the background music is playing