I updated Citra and now it won't load my data in Ultra Sun

When I tried to play Ultra Sun after updating Citra it says array size is too short


I’ve tried following guides and stuff online but and can’t get anything to work

citra_log.txt (48.9 KB)

System Information for Support

Client Version                                Nightly 1644 HEAD-2d972f9
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-9300H CPU @ 2.40GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1650/PCIe/SSE2
GPU Driver Version                            457.09
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Save states break across different citra versions. You need to load the save file on the citra version it was created on, otherwise it won’t work. You can find our older releases on our github page.

How do I run the older version?

Download citra-windows-mingw-20201115-23b6784.7z (direct link) from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1636
Extract it using Winrar or 7zip. Put the extracted folder anywhere you want. Now run citra-qt.exe from the folder and run your game.

It worked thank you so much :heart: