Im getting a fatal error when trying to save in pokemon alpha saphire

Issue:
Enter a description of your issue here, in full detail.

I transfered my save states from my home pc to my work pc, and while it worked fine, when I try to save in game, I get a fatal error.

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (32.3 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1728 HEAD-9019212
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 630
GPU Driver Version                            26.20.100.7986
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Save states can only be used on the Citra build they were created on. Therefore you trying to run them on your work PC when they were initially created on your home PC will result in them not working correctly. We recommend you use in-game saves instead of save states due to save states being unreliable and should only be used for single gaming sessions.

Please test if you also get the fatal error when not using save states. If so, upload another log file.

I have tried several times now to install the same version of citra on my work PC but Im still getting the error. I do use the save states and they work fine, but I want to trade pokemon between 2 clients and that needs to save.

Bumping this, this is a real issue now, I cant get past the elite four because the game automatically saves right before putting your pokemon in the hall of fame, resulting in a fatal error crash.

Autumn meant that save states cannot be used on a different Citra build than the one that they were created on. This has nothing to do with Citra versions. Save states record your build’s folder structure as well as the entirety of Citra’s state. If you attempt to load them on a different PC, the folder structure will be different. So even if you managed to get them to load in, they’re steadily breaking under the surface. The main reason why you’re having issues saving in-game is likely because the “Citra instance” that you’re running thinks that your folder structure is different from what it actually is, meaning that it can’t find the correct save folder, resulting in the error.

To test this out, does starting your game from your in-game save file and then saving in-game immediately after trigger the fatal error as well?