I'm trying to run Fire Emblem Fates, but have some issues

Issue:
When I run the rom, I can hear the music playing and if I press A a couple times, I can hear the options being selected for the game. However, the screen is just blank/gray, no black or white screen. Can someone help me with this?

System Information

  • Operating System: Mac Catalina 10.15.5
  • CPU: 1.6 GHz Dual-Core Intel Core i5
  • GPU: Intel HD Graphics 6000 1536 MB
  • Citra Version (found in title bar): Citra Nightly 1588
  • Game: Fire Emblem Fates
  • Screenshot of Issue (include the full Citra window including titlebar):

citra_log.txt (122.1 KB)

System Information for Support

Client Version                                Nightly 1588 HEAD-f4e727c
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i5-5250U CPU @ 1.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             Intel(R) HD Graphics 6000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

What I had to do was delete the shader file in the citra folder/shaders and then run it. Also run a debugger under View/debugging

Tell me if you can get it to work past the mode select though, cause I sure can’t!

I checked the shader folder and there was already nothing in it, and I tried using the graphics debugger? But I’m not really knowledgeable about this so I’m not sure if I’m doing it right, but the screen turned black now but the music is still playing and everything. The strange thing is, the graphics did work at first and I could select the mode before it froze, and it stopped working after. I enabled the accurate multiplications setting too but nothing improved.

like the whole shaders folder? the one one the User/AppData/Roaming/Citra/Shaders?

There should be one folder in the shader folder: opengl. There should then be two folders in that: precompiled and transferable. Those should all be empty. I’m also new so i don’t know about the rest, though

I found it and there are the two folders filled with few .bin files. So do I need to delete those or the whole shaders folder?

just the bins. Then run a debugger, at least that worked for me

Is the graphics debugger the right one to use?

Yes, I believe so. That or the pica vertex shader

Okay so the visuals just showed up now, but as usual it crashed after selecting the difficulty.

I have the same problem. In fact, there’s three topics about it within a few minutes of eachother, XD

I just want to play one of my favorite Fire Emblem Games :frowning: Do you know if Awakening has the same problem?

No, not for me. I’ve got through chapter 2, so far. I hope the citra team can get back to one of us fates fans, soon.

The screen just started to glitching with weird pixel color now

:cold_sweat:

Nice! I’ll try to get started on Awakening then. Thanks!

What debugger did you use?

the Pica Vertex one, though I’m not sure how to run it. It just showed up beside the screen.

1 Like

There is a bug on macOS where you need to resize the window or toggle fullscreen.

Do you know the specific size or if i need to do fullscreen? Or should I just test everything out?