Immense lag when playing phoenix wright dual destinies

Issue
Whenever I play phoenix wright dual destinies, i have 9-15 fps. i dont know how to fix it

  • Operating System: Windows 10
  • CPU: AMD Ryzen 7 1700 Eight-Core Processor
  • GPU: Radeon™ RX 550
  • Citra Version: Canary 1989
  • Game: Phoenix Wright Ace Attorney: Dual Destinies
  • Screenshot of Issue (include the full Citra window including titlebar):

(Screenshot is hard to read but it says 4 fps)

Diagnostic Log
citra_log.txt (16.3 KB)

System Information for Support

Client Version                                Canary 1989 HEAD-fe7e163
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 1700 Eight-Core Processor           | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon(TM) RX 550
GPU Driver Version                            19.40.38.02 26.20.14038.2009
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

System Information for Support

Client Version                                Canary 1989 HEAD-fe7e163
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 1700 Eight-Core Processor           | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon(TM) RX 550
GPU Driver Version                            19.40.38.02 26.20.14038.2009
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Try disabling Hardware Shaders, that sometimes improves performance for AMD GPUs. Additionally, you should try to see if not loading Save States helps as well. Please try to only use your in-game save files.

sadly it didn’t work, and it made the game worse in areas that used to be fine. any other solutions

Try going to Emulation>Configuration>System and set your CPU Clock Speed down to 50%. See if that has an impact of performance (keep in mind that underclocking like this is inherently unstable and may cause Citra to freeze).

Oh I tried to underclock and overclock already and nothing really changed (even though it worked for a different game I was playing that I had issues in), but I’ll try again just to make sure

i forgot to try the emulator again until just now, and I just tried to set my CPU clock speed down to 50%, but unfortunately nothing happened

also, another (maybe stupid) question. I have used the dolphin emulator, and every game had the same problem I am having here. I got it to work by enabling “Skip EFB Access from CPU.” I know that these two emulators work completely differently, but I was wondering if there was any setting that acts similar to the one on the dolphin? (Sorry if this is totally stupid question)

The only thing that comes close to that is the CPU Clock Speed underclock I mentioned. It basically skips some of the calculations that Citra does. So if Citra encounters calculations that are hard for it to execute, underclocking would have Citra “do less” per cycle. This means that a lot of those calculations are skipped. This generally results in less accuracy and even freezing on low enough underclocks (or overclocks for that matter).

However, I think that the performance issues in this case are mostly caused by AMD’s Windows OpenGL drivers. Which are terrible. You’d likely get around 3 times the performance when running Citra on Linux. The drivers there are just that much better.

Ah I see. Well I’m going to get a new graphics card soon, probably Nvidia, if Nvidia works well

Yea, NVIDIA currently has the best OpenGL drivers on Windows.
(NVIDIA>Intel>AMD)