Increased internal resolution doesn't display

Tried with Majora’s Mask 3D and Tri Force Heroes; both games with high-resolution screenshots & anti-aliasing on the Citra Screenshots page.

Setting the internal resolution to anything other than Native (400x240) produces a black screen. Audio can be heard as normal. Stretching the window enlarges the image but the resolution remains the same.

When starting the game at a higher resolution, the window still displays a 400x240 screen. Some garbled geometry occasionally shows.

Renderer settings:
(X) Enable Hardware Renderer
Internal Resolution: Native (400x240)
(X) Enable Hardware Shader
(_) Accurate Multiplication
(X) Accurate Geometry Shader
(X) Enable Shader JIT

I don’t know what those all mean, but I’ve tried every combination with no results.

System Information

  • Operating System: Windows 7 (64-bit)
  • CPU: i3, 1.7 GHz
  • GPU: ?
  • Citra Version: Nightly 1170citra_log.txt (70.6 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Your GPU driver is outdated.

Sorry this doesn’t help, you can find out what yours is called by opening this window:

You can get to that by pressing Start->right click on Computer->Properties:

Ahh, my bad.

Intel® Core™ i3-4010U CPU @ 1.70GHz

It’s a laptop and I don’t know much about the GPU. DirectX Diagnostic says Intel® HD Graphics Family, 1696 MB.

Windows says the driver is up-to-date.

Are you getting the driver directly from Intel’s website, or are you using Windows Update?
Windows Update doesn’t install the latest versions, and can sometimes install really old versions of drivers.

Can we get a screenshot?

1 Like


This driver is very outdated, it’s from 2015.

Get the latest here:

Since you are on a laptop you will most likely need to download the .zip version then follow this guide to install it:

1 Like


Thanks for the guidance so far.

I followed those links. From the Intel download center, selected Then, following the guide, selected “Have Disk” and browsed to the file igdlh64.inf and pressed OK.

Following that, the guide says that only the driver you’ve selected will appear in the list, and the image shows Intel® HD Graphics 520. But for me, there are 9 drivers in the list.
drivers1 drivers2

Now I probably didn’t download the same graphics driver from Intel, but I’m not sure why it’s showing 9, or which one to select.

Hm, strange that it doesn’t list HD 4400 for you which is what you would choose. Since Intel lists that here for the CPU:

The Citra log said you had HD 4400 but when you are trying to update it says “HD Graphics Family” at the top? Can you show what it says under display adapters in device manager?

See if you get a different result if you use the Assistant: