Incredible lag in Pokemon UltraSun

Issue:
I recently updated citra to its latest version and since then whenever i start the game my screen freezes at loading screen for solid couple of minutes and my game starts eventually but the speed is incredibly slow. I have been using auto window size graphics and no speed limit but now its doesn’t even work smooth at lowest native size graphics. It used to work at 100% avg in the last version.

System Information

  • Operating System: Windows 10 64 bits (latest update)
  • CPU: Intel i3 4030U @1.9GHz
  • GPU: Nvidia Geforce 820M (latest drivers checked)
  • Citra Version (found in title bar): Citra 1566
  • Game: Pokemon UltraSun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (92.2 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1566 HEAD-1504018
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-4030U CPU @ 1.90GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce 820M/PCIe/SSE2
GPU Driver Version                            369.09
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Also there’s currently a bug in Citra where you need to enable Accurate Multiplication if Disk Shader Cache is enabled. Else Citra would use more and more RAM until it slows down and finally crashes.

However with your CPU you can’t expect games to run at full speed. It has a single thread score of just 1020, recommended for good performance is a score of at least 1800.

edit: ok, forget what I said about the drivers, lol

1 Like

Latest driver for Fermi architecture is 391.35: https://www.nvidia.com/Download/driverResults.aspx/132845/

image
Source: https://www.nvidia.com/en-us/geforce/forums/discover/291552/what-is-the-latest-driver-version-for-nvidia-geforce-820m-of-laptop-/

2 Likes

But whenever if try to update drivers through GeForce Experience it says my drivers are up-to-date?

But I do play CS:Go and Valorant perfectly smooth on my build. Maybe I’ll try updating the drivers again and enabling accurate multiplication and get back to you

You can’t compare games that were natively written and optimized for Windows with an emulator that has to translate instructions that were meant to be only readable by the 3DS to something Windows can understand.

citra_log.txt (15.5 KB)

i didnt mean to compare that but i wanted to say that my drivers are fairly good to handle these games and citra was working perfectly smooth on native 4x before this new update

Yeah you should download the drivers I linked and perhaps check “clean install” under custom to make sure you start with fresh drivers. Then redo the stuff in Nvidia Control Panel so that Nvidia is the preferred GPU as well as Power management mode is set to Prefer maximum performance.

Thanks a lot @tywald and @space I did what y’all said and it’s working perfectly smooth again !!!

1 Like