Input problem on latest Canary build #798

#1

So, I came home today and updated Citra as I usually do everyday and there was only a Canary update.
After it finished, I went to play Monster Hunter Generations and noticed my Xbox controller had no response on it, and then, when I went to the input settings, the new inputs I was making were looking kinda weird, I will put a screenshot of it for anyone who wants to check out how the new input for the A button is looking when compared to the other old inputs. And also, the “set analog stick” options were not working. In the Nightly build and every other game I tried to play the controller was working fine. Is it happening to anyone else?

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

try to restore defaults and configure again.

#4

I also have this problem. Restoring defaults did restore the defaults, but did not allow proper input of the xbox controller. I had to roll back to a previous version in order to get it to recognize the xbox controler.

1 Like
#5

I’ve reported this to the Pull Request that I feel might be causing the issue.

1 Like
#6

On 799 I was able to reprogram my xbox inputs and it ran. But then the next time I loaded up the game it no longer responded until I once again reprogrammed the inputs.

Also, on the input config screen, I have to press the buttons like 5 times before it registers that I pushed it. And the analog stick input only works sometimes.

But the big thing is that even though it shows the exact same configuration as when I set it last time, it no longer registers the controller unless I redo all the inputs.

I am using and xbox 360 plug in controller.

#7

I have the exact same problem, I’m using an xbox one controller

It shows the inputs but wont work unless I reprogram them again

But it fails to program the analogue stick most of the time

#8

I’m using a PS4 Controller with DS4Windows, and I’m encountering the same issue here.

I’ve updated to 805 and everything. It will recognize button presses, but sometimes I have to press the button several times. And it won’t recognize either of the joysticks at all.

I also can’t seem to figure out how to roll back to a previous version. I grabbed 796 from this page, and ran it, but it had the same problem. I tried deleting all of my Citra folders and just using 796 like a new install, but still had the same problem. Any insight on how I can get a previous version running would be great, I’ve had to use Nightly in the meantime.

#9

either canary 795 or nightly, but prefer nightly while this issue is sort out.

#10

FYI, it seems like the problem is fixed in the latest build. You may have to reconfigure your input one time, but it should work after that.

1 Like