Installing Citra with Flatpak doesn't work - Key expired

Issue:
Hello, new person here. I use Ubuntu, and have tried to install Citra with Flatpak following these instructions. The Flatpak installation itself worked, but the last command line:
flatpak install https://flatpak.citra-emu.org/citra-nightly.flatpakref

Gave me this error:
error: Unable to load summary from remote citra-nightly-origin: Signature made mer. 21 oct. 2020 00:41:50 using RSA key ID F8B088B90782CA9B
BAD signature from " <[email protected]>"
Key expired lun. 26 oct. 2020 02:12:42

All I’ve found about this is:
- a reddit post from 15 days ago with the only answer saying to build from source — which looks pretty complicated to me.
- a GitHub issue from 4 days ago with no answer
- another GitHub issue from 15 days ago saying that the problem is being looked into.

I actually found the third one just now — so I’ll change my initial question to: is there anything new on this? I remembered trying to look it up and the internet somewhat telling me that only the devs can fix a key expiring.

System Information

  • Operating System: Ubuntu 20.04.1 LTS
  • CPU: AMD Ryzen 5 3500U
  • GPU: Radeon Vega Mobile Gfx
  • Citra Version (found in title bar): N/A? whichever’s in the flatpak
  • Game: N/A
  • Screenshot of Issue (include the full Citra window including titlebar): N/A

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
N/A

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Yes there is an issue with flatpak builds atm. You can download a standalone build at https://github.com/citra-emu/citra-nightly/releases/ then extract it somewhere. You should be able to start it from the terminal (make sure you are in the folder where citra-qt is) with ./citra-qt

You might need to download additional dependencies and maybe do chmod +x on citra-qt as well.

1 Like

Thanks for the answer!
With the help of someone more knowledgeable in terminal shenanigans than me, I managed to open Citra \o/

1 Like