Intel Core i7 vPro - Intel 520 - Suddenly yuzu has encountered an error while running the video core

Hi,

I have been playing Pokemon Let´s Go Pikachu without any problems until now, passed Brock and was heading to Mt. Moon. Suddenly, when I tried to continue playing yesterday, Yuzu suddenly did not let me play in Vulkan, stating that “yuzu has encountered an error while running the video core”.

yuzu_log.txt (47.1 KB)

While starting in Open GL, it frees at the title screen. Before, I had to play in Vulkan because Open GL caused too may problems. I am running an intel core i7 vPro with graphics card Intel 520. It was running super smooth, but it ran. No, nothing is happening. Any way out?

Yes, I updated my graphics drivers from here:
https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t470s/downloads/driver-list/component?name=Display%20and%20Video%20Graphics

Thanks
pghuerta

System Information for Support

Client Version                                yuzu 545             . HEAD-mainline-636-4747-g15a595064
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz | AVX2 | FMA
RAM                                           7.88 GB
Pagefile / Swap                               10.93 GB
CPU Emulation Accuracy Level                  1
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             Intel(R) HD Graphics 520
GPU Driver Version                            27.20.100.8854
Docked Mode                                   [ ]
CPU Multicore                                 [ ]
Async GPU                                     [x]
Assembly Shaders                              [x]
Async Shaders                                 [x]
GPU Emulation Accuracy Level                  High

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Vendor modified drivers are always VERY outdated. Do this, as Intel removed the restriction on official drivers now:
Get the zip version of the latest driver from here: https://downloadcenter.intel.com/download/30248/
Follow the instructions here: https://www.youtube.com/watch?v=BZG50Nm5sOM&t=72s
You will need to select iigd_dch.inf

Hi,

Thank you very much for your input, it did work. Is there any way to not having the game crash every 10-15 minutes? A best configuration or any tip?

Best regards
pghuerta

Can you post me a log file after one of the crashes?

Hi,

Thanks for answering! I just played and it crashed. As I said, it´s playable, but it crashes every 10 minutes. Now it´s still fine, but when the combats will last longer, I will have problems to finish those…

Log file below:

yuzu_log.txt (968.0 KB)

Cheers
pghuerta

System Information for Support

Client Version                                yuzu 549             . HEAD-mainline-636-4756-gc648152b4
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz | AVX2 | FMA
RAM                                           7.88 GB
Pagefile / Swap                               4.75 GB
CPU Emulation Accuracy Level                  1
Graphics API                                  Vulkan 1.2.167
Graphics Renderer                             Intel(R) HD Graphics 520
GPU Driver Version                            Intel Corporation 100.9313
Docked Mode                                   [ ]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [ ]
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The crashes after 15 minutes may be related to our Vulkan implementation, we’re working to implement a way to remove unused assets before VRAM gets full. Intel GPUs set up very small amounts of shared memory on their iGPUs, making this problem more common on them.

Can you try if this new driver solves OpenGL?

Hi,

First try: Game crashes in title screen.

yuzu_log.txt (191.6 KB)

yuzu_log.txt.old.txt (216.6 KB)

Second try:
The game freezes with a black screen when I go out of a building. I keep hearing the music, but nothing is moving.

Third try: Following some tutorials on YouTube for graphics configuration, no success with OpenGL.

yuzu_log.txt (83.6 KB)

Forth try:

I put again Vulkan, same issue, even earlier.

yuzu_log.txt (827.4 KB)

Somehow, the game simply does not run in OpenGL. In Vulkan, it runs, but not smooth and it crashes…

This seems to be related to recent memory problems.
We’re working on fixes for them, make sure to keep yuzu updated in the coming days.

What can be the problem in OpenGL?

It would affect both backends, the driver will react in different ways on each of them.