Is there a way to increase analog stick sensitivity so that characters run at full speed?

Regardless of the fact that I have used the “set analog stick” feature within Citra and used the calibration tool within the Windows Game Controller tool; my character runs too slow when playing Ocarina of Time 3D witch makes the game unplayable because Link wont jump properly.
I am using a Nintendo Switch Pro Controller.

I could not find any solutions to this problem elsewhere.

System Information

  • Operating System: Windows 7
  • CPU: AMD A10-5800K APU with Radeon™ HD Graphics 3.80 GHz
  • GPU: NVIDIA GeForce GTX 1060 3GB
  • Citra Version (found in title bar): Nightly 1467
  • Game: The Legend of Zelda Ocarina of Time 3D
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (24.2 KB)

In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                                Nightly 1467 HEAD-f75cc8b
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1060 3GB/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            388.13
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

Here’s some issues I found with your log that might help.

How does your controller behave in joy.cpl(Windows’ gamepad settings)? Does it reach to the edges in the X/Y axis?

Strange that the calibration didn’t work, though this user had a gamecube controller:

Citra pretty much just behaves the same as Windows’, do you use a 3rd party software for the Pro Controller?(like I use SCPToolkit for DS3).

Nearly, not perfectly on all edges but on some.

I have Proconxinput.

It would make sense that it would work with a gamecube controller because it has the octagonal notches around the edge of the analog stick that give it more range. I’m wondering if I can mitigate my lack of range with software or by re-coding something.

Bump Bump Bump Bump …
I’m not sure if I was given up on here.

Another user today with the same problem, but again not the same controller and was fixed with calibration. (need to click on the screenshot to see the rest of the conversation).

Yeah, sorry I have no idea how to fix for the Pro Controller unfortunately :frowning:

Can you test Nightly 1564? then compare with Nightly 1565.

Any solution to this?
It happens to me as well, with Majora’s Mask 3D and also with Switch Pro Controller mapped through Steam.
When I map it digitally, I can run fine, although the diagonal movements are not nice. When I map it Analog, it runs super slow even if I tilt the stick the most.

1 Like

Having the same issue. Link will not run if I map using Configure → Controls → Set Analog Stick for the Circle Pad, but if I set the axis manually, he won’t walk or turn at all, so it’s extremely difficult to make precise jumps. Any ideas??

Using Original Gamecube Controller with Mayflash Adapter in Wii U Mod w/ GC USB Adapter Device (vJoy)