Issue: Whenever the game is loading it just stops the visuals but I can still hear the background music and when I move my character I can also hear the footsteps. I currently just saved and load the game then restart but it no longer worked

Continuing the discussion from Monster Hunter 4 Ultimate Loading Screen Stuck:

Issue:
Whenever the game is loading it just stops the visuals but I can still hear the background music and when I move my character I can also hear the footsteps. I currently just saved and load the game then restart but it no longer worked

System information

Operating System: Windows 10 pro 64 bi
CPU: Intel(R) Core™ i7-4790K CPU @ 4.00GHz 4.00 GHz
GPU: Interl(R) HD Graphics 4600
Citra Version: 1714

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt.old.txt (24.3 KB)

System Information for Support

Client Version                                Nightly 1714 HEAD-5241032
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4600
GPU Driver Version                            20.19.15.4531
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

GPU Driver Version: 20.19.15.4531

This driver is outdated, you will need to update it.

Download win64_15.40.5171.zip from https://downloadcenter.intel.com/download/30196/Intel-Graphics-Driver-for-Windows-15-40-
direct link: https://downloadmirror.intel.com/30196/a08/win64_15.40.5171.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Since your iGPU has driver bugs, you may also need to turn off Accurate Multiplication in the Advanced graphics settings in Citra configuration.

Did you always run with integrated graphics on this computer? Since it’s a high-end CPU from 2014 I expected to see something like a GTX 780. I had an i7-3770K with GTX 680.

Haswell & Devil’s Canyon iGPUs are buggy so if you can, try get an Nvidia graphics card for much better performance (you can even play MHW easily if you do. I could maintain 60 fps consistently on i7-3770K with GTX 1070 at medium-high settings but you wouldn’t with Intel HD 4600).

My gpu broke down and I can’t find a new one. I’ve been using citra but ever since I lost my gpu I just thought it would still load since it matched the requirements.

Ah I see, that is unfortunate. Well just follow the links above to update your integrated graphics and turn off Accurate Multiplication as mentioned above and you should at least be able to run it.

Sadly it didn’t work, so I tried it to a new game and reinstalled everything and still it didn’t work
citra_log.txt (5.8 KB)
citra_log.txt.old.txt (20.4 KB)
here’s my log. Advanced thank you

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1715 HEAD-afed495
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4600
GPU Driver Version                            20.19.15.5171
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 0
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Make sure you’re not using Save States when testing this. Save States are generally speaking pretty unreliable when troubleshooting something as they save Citra’s entire state, not just the game’s state. Meaning that any error in the emulation gets saved along with them.

I guess this issue is due to the “AMD hack” removal for non AMD GPUs. It might work on latest if you turn off Hardware Shader.

Otherwise you can try Nightly 860: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-860.

Intel HD Graphics stuff… :confused: You might need to add a new graphics card in the near future, prices are going down last time I heard. Make sure you pick Nvidia to get the best performance.