Issue with audio syncing

Issue:
My button presses are clearly synced to video instead of audio, (which it should be for any other game) but I’m playing Rhythm Heaven Megamix and the slight delay in audio is tripping me up. How do i sync my inputs to the audio? or just prioritise correctly timed audio over video in Citra.

System Information:
Operating System: Windows 11
CPU: 11th gen Intel Core i7
GPU: Intel Iris Xe Graphics
Citra Version: Citra Nightly 1795
Game: Rhythm Heaven Megamix

Diagnostic Log:
citra_log.txt (24.7 KB)

System Information for Support

Client Version                               Nightly 1795   HEAD-1759e2a
Operating System                             Windows 10 Version 2009
CPU                                          11th Gen Intel(R) Core(TM) i7-1165G7 @ 2.80GHz | AVX512 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) Iris(R) Xe MAX Graphics
GPU Driver Version                           30.0.101.1003
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

Go to Emulation>Configuration>Audio and disable Audio Stretching. Then go to Emulation>Configuration>Graphics>Advanced Tab and disable V-Sync. Those should reduce the amount of input lag you receive. Let me know if the issue persists.