I've tried every solution I've found online, but citra always crashes

Issue:
Enter a description of your issue here, in full detail.

System Information

  • Operating System: window 10 64 bit
  • CPU: i5-7200U 2.50GHZ
  • GPU: Intel® HD Graphics 620
  • Citra Version (found in title bar): Nightly 1548
  • Game: Mario & Luigi: Dream Team
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (16.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1548 HEAD-51dfc46
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

GPU Driver Version: Build 23.20.16.4973

This driver is outdated, you need to update.

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed that download and install igfx_win10_100.8190.exe from: https://downloadcenter.intel.com/download/29557/Intel-Graphics-Windows-10-DCH-Drivers?product=95443
direct link: https://downloadmirror.intel.com/29557/eng/igfx_win10_100.8190.exe

Also do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder(if it’s there)
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Thank you for responding, but this sadly didn’t fix my issue.

Thank you for all of your suggestions, and I’m sure the new drivers will 100% improve my computer.

But sadly, when I tried to run the game, citra still crashed.

Here’s my log in case anything changed:
citra_log.txt (4.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Did you do the last part in my previous post? (especially with deleting the opengl folder). You can enable Disk Shader Cache again after you have done it.

Kernel <Critical> core/hle/kernel/resource_limit.cpp:GetForCategory:33: Unknown resource limit category
Debug <Critical> core/hle/kernel/resource_limit.cpp:operator():34: Unreachable code!

Though you might have to redump the game using the guides below and have at least 4GB free space on your Nintendo 3DS’s SD card before you dump.


When I looked into my shaders folder, it was empty.

But I’ll try redumping the game.