Joycon Input Delay

Issue:
Decided to finally start using Citra as of yesterday and I must say it’s been so easy to use. Playing OOT and PersonaQ 1 & 2 for right now. In OOT I got a bit sick of no gyro controls on my xBone controller, so I went through the deal of setting it up. I only can really use my joycons for motion right now, so I used BetterJoyForCemu. All that jazz. I must admit, the motion does work. However, the problem is, as you can guess from the title, that there’s a delay between when I move my controllers and when the camera moves. It’s no small delay either, it’s like a full second or two. Anyone else have this problem? Found the solution? Much appreciated.
EDIT: oh. Thought it was just motion controls, but no. It’s a delay with everything on the now controller. Fun

System Information

  • Operating System: Windows 10 1803
  • CPU: Intel i7-7500U
  • GPU: Nvidia 940mx
  • Citra Version (found in title bar): 1319
  • Game: Ocarina of Time

citra_log.txt (71.1 KB)

Problem Showcase Video

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1319 HEAD-76aec4d
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 940MX/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1319 HEAD-76aec4d
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 940MX/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.