Just installed citra and i wont even let me select the directory where the games are and will just wont respond

Enter a description of your issue here, in full detail.
Ok so i tried this with nightly citra and canari citra old versions new versions manual install normal install everything i thought about and after the telemetry pop up citra will just not answer to my clicks and few seconds later it has the “It doesnt respond” thing. I swear I dont know how to fix it anymore. I tried it on my desktop and it runs just fine but on my laptop it wont work.
Please help.

System Information

  • Operating System: Windows 10
  • CPU: AMD5700
  • GPU: RTX3050 4G
  • Citra Version (found in title bar): 2006
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):
    citra_log.txt.old.txt (240 Bytes)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

Please test again on the latest Citra Nightly build. If the issue persists, try the MSVC build from here: Release nightly-2015 · citra-emu/citra-nightly · GitHub