Just returned to Citra: Can't join any network rooms

Enter a description of your issue here, in full detail.

I can’t connect to any network rooms. I tried reverifying my token/username, tried regenerating a console ID, and my internet itself runs fine, nothing is working. A few months ago I could connect to any room just fine, but now I cannot. Note that its not a PC issue either as my girlfriend cannot connect to any room either from her laptop.

Can anyone help? :slight_smile:

Thank you in advance.

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar): Nightly 1178 but tried other versions, no connection possible
  • Game: Pokémon Ultra Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Execute citra as admin :smiley:


Thank for the tip m8, I actually hadn’t tried that haha. Unfortunately that doesn’t work either :(. Still won’t let me connect to any room.

Any other ideas by chance?

Check your username and token again to see if the it is working. relaunch citra and try again. do other rooms work?


I’ll check that stuff again. No rooms work at all atm.

Try resetting your network, close citra and run the following commands on CMD:
ipconfig /release
ipconfig /renew
ipconfig /flushdns


Thanks for the advice m8. I just tried going through and reverifying my account and regenerating a new id.

I also followed the router reset/command prompt steps you suggested twice.

Unfortunately none of that worked either. I’m still unable to connect to any room.

I appreciate the help though, any other ideas by chance? I’ve had issues connecting in the past but one of the things I’ve tried always fixed it. This is really weird.

Just wanted to note that my girlfriend and I can make our own unlisted room and connect, we are just totally unable to connect to any public room whatsoever.

Maybe your antivirus blocked citra, add an exception for citra-qt.exe and citra-room.exe on your antivirus, including windows defender.


Thanks again for the advice. I just added exceptions for all 3 citra executables but I still can’t connect. Also tried turning the firewall completely off to test, but that also had no effect.

Maaan this is lame, the multiplayer features on Citra are incredibly fun and it’s rough not being able to access any of it. I’m totally out of ideas :(.

Try again and upload your log. you can also try the following:
Close citra and delete the qt-config.ini file on C:\Users\%username%\AppData\Roaming\citra\config, launch citra again, you have to configure it again, configure your username and token, try connecting again.

@bio3c Hey thanks again for the help, been busy so haven’t had a lot of time to work on Citra things.

Worked on it a bit today though, tried your latest recommendations. Deleted the config.ini and reconfigured the emulator, including reverifying token and generating a new console id.

Still cannot connect to any public rooms. I’ll attach my log with this latest post, hopefully you or someone else can figure out the issue from it.

citra_log.txt (260.1 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

1 Like

Close citra, open ‘Windows Firewall with Advanced Security’, click on ‘Inbound Rules’, find any entry for ‘citra-qt’, right click on it and delete it. do the same on ‘Outbound Rules’. update citra and open it, don’t launch any game, go to Emulation > Configure > General > Debug and check ‘Global Log filter’ from *:Info to *:Debug. now try connecting to several rooms. upload your log afterwards.


this worked for me when i had this problem this morning (what bio3c said)

btw you should change the ‘Global Log Filter’ back, that was just to get more info about what was happening, as *:Debug will create huge log files and slowdown emulation.

Is this solve I still get this kinda of error too

Some rooms aren’t setup correctly(most likely the hosts haven’t port forwarded correctly).

Actually for me yeah, turned out my router was occasionally blockeing online gaming of any sort. No idea why. Did a factory reset of the router and poof, all was well.

1 Like