Keyboard controls not working properly

Issue:
citra_log.txt (42.5 KB)


Hi,

Whenever I try to change the control settings, the error from the screenshot shows up. The whole reason why I had to attempt changing the controls was because regardless of the game loaded, only a few buttons work. For instance, my arrow keys work and the A button works. But B and everything else are unavailable. Sometimes it works fine after clearing and restoring the settings.

Please help.

Thank you

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 1600 (6 core 3.2 Ghz)
  • GPU: NVIDIA GeForce GTX 1060 6GB
  • Citra Version (found in title bar): Canary 1959
  • Game: N/A
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1959 HEAD-651c9d0
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 1600 Six-Core Processor             | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1060 6GB/PCIe/SSE2
GPU Driver Version                            456.71
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Can you give an example (in order) what to bind to trigger this? What is your keyboard settings in Windows set to, US keyboard?

Thank you for your response.
Yes, my keyboard is set to English (US).

Well, it started off with the keys not responding at all, other than either the A or B button and the direction keys. So, I went ahead and reset all settings and nothing happened. Then I went in to controls, cleared all bindings and restored the defaults. No change in how the keys responded. Then I cleared it all again and tried to manually set the controls. When I try to set the key for A button, some other alphabet other than the one I pressed shows up.(Only once or twice did I get the pressed key to come up) And then every key other key I try to bind, gives the error from the screenshot.

Can you give me a sequence that would end up with this error every time so I can try out on my end?

Emulation > Configure >Controls > [Clear All] > Assign buttons.

Only the first one gets assigned.

Update: I managed to get it working again. It was not a Citra issue. I went to safe mode and tried it out and it worked. Eventually I ended up disabling the AV and found that it was the Anti-Keylogger module that caused this issue. Thank you so much for the support, tywald. And sincere apologies for wasting your time!

1 Like