Kid Icarus runs bad

Issue:
The first game I tried using for Citra is Kid Icarus. I had not tried any other. Kid Icarus runs like as$. There is no reason for it to run this bad I thought I was doing something wrong. I runs at about 18-20 FPS on default settings. I tried upscaling it a little for a glorious 10 FPS. I tried messing about even with clock speed or emulation speed but nothing.

I tried Super Mario 3D Land. Other than some stutters it seems to get stable 60FPS

System Information

Upscaled 10FPS

Diagnostic Log
citra_log.txt (1.4 MB)

System Information for Support

Client Version                               Nightly 1776   HEAD-6764264
Operating System                             Windows 10 (10.0)
CPU                                          12th Gen Intel(R) Core(TM) i7-12700F | AVX2 | FMA
Graphics API                                 OpenGL 3.3.1
Graphics Renderer                            AMD Radeon RX 6900 XT
GPU Driver Version                           22.Q2 30.0.21020.2
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

So it is AMD’s fault then?

I tested out Ocarina of Time and Majora’s mask for a little while on my old saves. Other than the stutters they run at 30FPS with some audio issues. The audio is set to fast so I don’t know.

I’m going to thank everyone who replied to me for your amazing suggestions…

I had to download a very specific version of AMD Adrenalin Driver or whatever