Kirby Planet Robobot lagging

Issue:
The game lags, constantly dipping around 15-20FPS. Whenever I try to exit the emulator, it speeds up on the titlescreen, but playing the game is generally very slow and not super performative.

System Information

  • Operating System: Windows 10 64-bit
  • CPU: Intel(R) Core™ i5-1035G1 CPU @ 1.00GHz 1.19 GHz
  • GPU: Intel(R) UHD Graphics
  • Citra Version (found in title bar): Citra Nightly 1815
  • Game: Kirby Planet Robobot

Diagnostic Log
citra_log.txt (22.7 KB)

System Information for Support

Client Version                               Nightly 1815   HEAD-d09f6d9
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz | AVX512 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) UHD Graphics
GPU Driver Version                           30.0.101.3111
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [ ]
System Region                                1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

With Accurate Multiplication, it still stutters quite a bit. V-Sync also didn’t make too much of a difference

Go to Emulation>Configuration>Graphics>Advanced Tab and enable Shader JIT.
Additionally, please do not use save states whilst testing this. Save states save your Citra configuration at the time of saving. Which means that upon loading them, your Citra settings from when the save state was saved are applied once again.