Kirby Star Allies Crashes after loading

After the game is loaded, there is another loading screen with kirby hear in the bottom right corner. But after a few seconds, yuzu just crashed. Here’s my log file. TIA!

yuzu_log.txt (36.6 KB)

System Information for Support

Client Version                                yuzu 431             . HEAD-mainline-636-3730-g09b772e0a
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                  OpenGL 4.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            26.20.100.8142
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

1 Like

yuzu will not run with only 4GB of RAM, 8GB are required.

1 Like

So i guess i need to go to a local store to change RAM? btw, thank you for the super quick reply!

1 Like

Yes, besides that, a bigger page file and a newer driver are required, but without having at least 8GB first, it would be worthless.

1 Like

You mean newer “graphic” drive? Or what kinds of drive are you talking about? Thank you!

No, I mean using the latest driver for your GPU. The software in charge of communicating the GPU with the operating system.

Got it. Thanks a lot!