Kirby Triple Deluxe Crashes upon startup, all other games work fine

Issue:
Lately, I’ve been experiencing problems with trying to get Kirby: Triple Deluxe to even start up, when I click on the game to try and start it, It takes a really long time “Loading Shaders”. After about a minute, a window pops up saying Citra has crashed, or the program just closes itself, without any message. What’s weird, is that this only happens with Kirby: Triple Deluxe, and not other games like Kirby: Planet Robobot or Super Mario 3D Land, where the game starts pretty much instantly without even any “Loading Shaders” thing, the game just starts up, no issue. If anyone knows the solution to this issue and could tell me how to fix it, that would be wonderful, thank you.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-3570K @ 3.40 GHz
  • GPU: AMD Radeon RX 6600
  • Citra Version (found in title bar): Citra Canary 2239
  • Game: Kirby: Triple Deluxe
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (16.9 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

Please update to the latest Citra Canary version available. Additionally, set your CPU Clock Speed slider back to 100% in Emulation>Configuration>System, you shouldn’t be touching this unless you know what you’re doing. And lastly, disable Dump Textures in Emulation>Configuration>Graphics.

It worked, and I am able to finally play it again. Thank you!