Kirby: Triple Deluxe game loading

Issue:
Enter a description of your issue here, in full detail.
When playing Kirby Triple Deluxe, I am noticing every single time I want to start thr game up, the loading shaders screen keeps getting bigger and bigger. At first it was 15206, then it was 17000, and this is like my 7th or 8th starting the game up and it is saying there are 28163 shaders to load, which makes the loading time longer and longer.

System Information

  • Operating System: Windows 10?
  • CPU: Intel ® Core™ i5-1035G1 CPU
  • GPU: Intel ® UHD Graphics
  • Citra Version (found in title bar): Citra Nightly 1628
  • Game: Kirby Triple Deluxe
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (15.3 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1628 HEAD-1c8461f
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            26.20.100.7870
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

Hi, please try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Citra->preferences… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.