Lagging and Freezing while using Vulkan

In yuzu open gl working a bit slow but whenever I switch to Vulkan the emulator become too slow and shows (not responding) . how do i fix this?

My pc specs :
Core - AMD Ryzen 5 3400g with radeon vega graphics 3.70 GHz
Ram - 8 gb
OS - windows 10 (64bit)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

You are most likely running out of RAM. Vulkan needs a good amount of VRAM and you have no dedicated graphics card so the normal ram is shared for this. 8 GB RAM is already quite little for yuzu and your graphics card is taking part of that which exacerbates the issue. You can try setting a large pagefile but that will hurt performance as well although that should stop it from crashing because of running out of RAM.

1 Like

If i get another 8gb of ram will it be sufficient ?
also how do I set large pagefile as you mentioned?

yes, getting another 8GB would be a lot better. With the current situation I would set the pagefile at like 16GB (set it minimum and maximum 16GB so it doesn’t resize it all the time)

1 Like

how do I set it can you show me the steps , i have no idea about it

Or just google it.

1 Like

and set it to 16 gb , i mean around 16000mb?

yes, that is what I said

1 Like

Thanks for all the help :slight_smile:

no problem :slightly_smiling_face: