Latest Citra update made performance slower - HEAD-55680b0


#1

Issue:
I have just updated my Citra, like 10 min ago. Before, playing Pokemon Ultra Moon i was getting 32-45 fps with a high resolution. Now i’m barely reaching in 30 fps. It would be good if there were a way to come back to the previous updates. Help?

System Information

  • Operating System: Windows 64bit
  • CPU: i3 2120
  • GPU: r9 290
  • Citra Version: HEAD-55680b0
  • Game: Pokemon Ultra Moon

My log: citra_log.txt (301.9 KB)


#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.


#3

I did not find anything wrong in your log file. Please wait for a moderator to assist.


#4

Please update to the latest Canary build.


#5

Me and a friend are having a similar issue with MHXX, performance seems to be about 2-3x worse than it used to be. He’s getting about 8-10fps in places where he had 30, and I’m getting about 2x higher frametime (from ~6ms it jumped to 12ms) in the same places and whereas lifting the limiter gave me ~60fps before, now it barely breaks 40. Seems to have slowly started happening over the last week or so of updates.


#6

I’ve noticed that from when shadows on MHXX have been implemented, i get this issue when I disable 3D mode:

Also on Mario Kart 7, there has been an aggravation of performance in the last canary versions (especially in some locations like Flower Cup)


#7

That issue is caused by your Nvidia GPU. Check here for a solution.


#8

Thank you, this has fixed the artifact issue


#9

Now with the version HEAD-4687ee7 i can get more fps, but only if i unmark “accurate multiplication” and “accurate geometry shader” (before i couldn’t), which are new settings, i believe.


#10

They aren’t new. The settings can do the same thing as before, but now its checkboxes instead of dropdowns