Launch games in Citra directly through shortcut


#1

Issue:
I want to directly launch a game in Citra in fullscreen by clicking on a created shortcut. I am trying to do this by making a shortcut of citra-qt.exe and typing the following commands in the Properties box of the created shortcut:
In the Target field I type: “my citra-qt.exe path” -g “my game.3ds path” -f
In the Start In field I type the path to the folder containing citra-qt.exe

When I do this and I double click on the shortcut, Citra itself launches fine but immediately an error pops up saying that “the ROM format is not supported”. However, when I launch citra-qt.exe by myself and select the game, it launches normally.

What am I doing wrong here and how to fix this?


#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.


#3

your directory path may have spaces, maybe your could put an ‘at’ @ symbol in front of the path
(e.g: @C:\Program Files…)
or surround or path string with double-quotes + slash "\ before and after each double quotes
(e.g: “\“C:\Users\Name\Desktop\Roms\mygame.3ds\””)


#4

Thanks for your reply. Just tried your suggestion and it didn’t work. Same error appears.


#5

i created a shortcut with target like this:
D:\Local\Emulators\citra\canary-mingw\citra-qt.exe “D:\Games\3DS\MyGame.3ds”

it worked!


#6

also, the -f argument only works for citra.exe, citra-qt.exe expects a proper rom file.


#7

This did it for me! Thanks a lot. Apparently, the “-g” is not suited for Citra but needed for Cemu for some reason. Regarding the -f argument, how do I launch a game in citra.exe instead of citra-qt.exe? For a very short time a command prompt pops up and disappears again.


#8

Use citra.exe instead of citra-qt.exe in the command?


#9

You mean putting that command in the target field? I indeed did that but I get the issue I described above.


#10

he meant like this, e.g:
D:\canary-mingw\citra.exe -f “D:\Rom\MyGame.3ds”


#11

You’ll need to tell us exactly what command you’re using.


#12

This indeed worked! I was putting the “-f” at the end of the whole line. However, the game has a very low resolution (even though I have it set at my screen resolution for citra-qt.exe) and I can not change the screen-layout like in citra-qt.exe. Doesn’t citra.exe have any settings like citra-qt.exe?


#13

since citra.exe has no interface, you need to configure the sdl2-config.ini file located at:
C:\Users%username%\AppData\Roaming\Citra\config\

but i think it would be easier to usa citra-qt,exe and press ‘F11’ to switch to fullscreen.
also if you switch to fullscreen, citra will never leave fullscreen as long as you close it with fullscreen enable, unfortunately it does fullscreen by projecting it’s window on top of everything, meaning that if you send a kill command like alt+f or alt +f4 you will have to alt+tab to see the close app dialogue.


#14

Thanks. So I tried changing some settings regarding in the config file.
I want to have a resolution of 1920 x 1080 (my monitor resolution) and the screen-layout “Large Screen Small Screen”. I tried putting the corresponding numbers for those settings in the sdl2-config.ini but they don’t work.
Here’s how I did it (I deliberately put a “-” before each line in this post because the # sign increases the font size for some reason here) :

-# Resolution scale factor
-# 0: Auto (scales resolution to window size), 1: Native 3DS screen resolution, Otherwise a scale
-# factor for the 3DS resolution
resolution_factor = 0

[Layout]
-# Layout for the screen inside the render window.
-# 0 (default): Default Top Bottom Screen, 1: Single Screen Only, 2: Large Screen Small Screen, 3: Side by Side
layout_option = 2

Why aren’t they working?


#15

Side note, that is markdown formatting. # is used for header 1. That’s why the font is large. You can wrap your text/code in a code block with ``` instead. So it would look like this.

# Resolution scale factor
# 0: Auto (scales resolution to window size), 1: Native 3DS screen resolution, Otherwise a scale
# factor for the 3DS resolution
resolution_factor = 0

[Layout]
# Layout for the screen inside the render window.
# 0 (default): Default Top Bottom Screen, 1: Single Screen Only, 2: Large Screen Small Screen, 3: Side by Side
layout_option = 2

As for your issue, I can confirm that the internal resolution does not change in fullscreen mode but layouts does work. Using 0 or 10 does not change the internal resolution. Taking screenshots with Game DVR results in an image that is 640 x 480 in resolution instead of the usual 1920 x 1080.

Citra%20Nightly%20_%20HEAD-cf9bfe0%20%206_12_2018%207_20_35%20PM

@Adityarup_Laha didn’t you write the code for fullscreen with sdl frontend?


#16

Yup I did. Can you check if the internal resolution changes after resizing?


#17

the resizing only affects the window mode, it has no effect on fullscreen.


#18

That’s not what I needed. I need to know if window size affects resolution in auto mode. It should. In that case, I will have to fix it. Otherwise, I won’t be able to, as I’m not that good.


#19

in windows mode, yes.

on fullscreen, hard to tell since it’s 640x480
but i don’t think it does when i compared screenshots.
but resolution factor does affect fullscreen.


#20

So, auto doesn’t readjust resolution when you resize the window?