Layton miracle mask suddenly running slow

Last week trying to play the game the speed went from 100 to 75% when initiating a cut scene. I tried looking at settings like audio and graphics. But nothing seemed to work. Last time (1st May 2023) it worked completely fine. Already tried changing settings like audio without any succes. Now I made up some free space and updated citra but now the speed is going from 100 to 60/50% after a few minutes playing. I also found online different people with the same problem. Updating drivers worked for them. Unfortunately that also didn’t work for me. (I did restart my PC after updating)

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 2600 Six-Core Processor 3.40 GHz
  • GPU: NVIDIA GeForce GTX 1650
  • Citra Version (found in title bar): 1909
  • Game: Professor Layton and the Miracle Mask Dutch (en het Masker der Wonderen)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (586.1 KB)

Go to Emulation>Configuration>Graphics>Advanced tab and re-enable Hardware Shaders and Shader JIT. There’s no reason to turn these off.

Go back to the Graphics settings and disable Dump Textures → This option is only useful for those that are interested in creating their own custom textures.
You may also want to delete all the textures it’s dumped so far: Go to File>Open Citra Folder, then open up the dump folder and delete the textures folder found here (this will delete all dumped textures for all of your games).

Now try your game again.

1 Like

I tried but I still got speed loss after a few minutes. I do want to thank you for your help!

Please upload a new log file after the performance loss.

1 Like

This is the new log.
citra_log.txt (543.8 KB)

Are you loading a save state?

1 Like

No I do not. I did load the savestates the last session I played and then loaded the hard saved this session. (I do always save both ways)
After updating Citra my savestates do not work for this game. (don’t know about my other games bc I haven’t played them)

We ask, because the things I told you to change are back to what they were before, so it makes sense that your performance is horrible again. Save states save your settings as well. So if you’ve loaded a save state in between your previous session and this one, your settings will have changed back to your old ones.

Oke, that I did not know. I did use the hard save now and switch between the graphics API (to software). It got worse at first but when I turned it back to openGL it seems to work again. Thank you both so much!