Layton's Mystery Journey, can't see text

Issue:
I can’t see any text in the game, doesn’t matter if it’s a text box or a puzzle hint, I can’t see anything. Do I need to put the code for an error like this anyway?

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-4210U 1.70GHz 2.40 GHz
  • GPU: Geforce 920m
  • Citra Version (found in title bar): HEAD-9e4f670
  • Game: Layton’s Mystery Journey: Katrielle and the Millionaires’ Conspiracy
  • Screenshot of Issue (include the full Citra window including titlebar): https://imgur.com/a/yXhLt

Log:
https://pastebin.com/q8qbLUsQ

Looks like a region problem. What is the game’s region and what region is set in Emulation - Configure - General ?

Have you also tried dumping the system archives?

The game’s region is USA I remember when I downloaded it, and mine is set to Europe. No I didn’t try dumping files because it’s complex
EDIT: I tried changing my region to USA and nothing changed

Some games require you to dump certain files from your 3DS. Please refer to our System Dumping Guide.

Please read our Community Guidelines. Warez/downloading games talk is strictly prohibited. To prevent legal issues, you are not allowed to post links or refer to any kind of ROM, NAND, ISO, game, or other copyrighted material that has been illegally obtained or shared. This includes system files, and files from friends.

Citra requires you to dump your cartridges/installed titles from your 3DS. Please refer to our Game Dumping Guides:

Dumping Game Cartridges
Dumping Installed Titles