Link between Worlds EUR: emu hangs when I try to load my save

Issue:
I saved my game in Kakariko village, but when I’m trying to load my save, emulator hangs on loading (spinning triforce) screen. I have to kill emulator, it stops responding. I tried disabling disk shader cache, it didn’t help.

System Information

  • Operating System: Linux Fedora 34
  • CPU: Intel Core i7 3630QM
  • GPU: GeForce 740M
  • Citra Version (found in title bar): master-a2f34ea82 (citra-nightly)
  • Game: Link between Worlds EUR
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (21.4 KB)
Message about unmapped Read32 keep multiplying with increasing address values, log file grows to many megabytes.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

The game title screen shows Kakariko village when save exists and if I don’t do anything for a while, the game should show some backstory, but also hangs. This does not happen if I remove the save. Kakariko problem?
I can share my save: nand_sdmc.7z — Яндекс.Диск

No issues loading your save here:

Maybe the rom is corrupted? Try redump it by following the guides below, make sure you have enough free space on your Nintendo 3DS’s SD card:

Thanks for your response, unfortunately, redumping didn’t help. However I noticed that my saves load just fine unless I activate streetpass by talking to Gramps. If streetpass is activated and then I save, I can’t load that save anymore. What version of Citra have you used to load my save? I could bisect the problem.

I tried to download windows nightly version and my save loads just fine in it. Either it’s linux specific problem, or I built citra with some wrong flags.

Same problem here with weihuoya-citra on android…

It has to do something with street pass support. All but windows version mishandle street pass memory region. I recommend not to activate street pass as a workaround.