Link's Awakening - X + Y won't work but the rest of controls do

I have just recently been trying out yuzu, metroid dread works flawless so far… but when i tried out link’s awakening, it mostly worked… but the x and y keys dont seem to let me equip them in the inventory function, as such i cannot use items.

the attack button and talk button and L / R shield button, all seem to work… but when i go into the inventory the mapped X + Y buttons do not let me equip items. they are simply unresponsive. In the controller config they light up as if they are working… so i have no idea but i cannot progress without equipping things. any ideas? thanks

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I am using an older logitech dual action controller. every other button works, and the 2 buttons in question work flawlessly in metroid… so its not a hardware issue. i have no idea why it wont let me equip items in links awakening?

What emulated input are you using on the game?