[Linux] CItra won't load installed games on virtualSD in an NTFS partition

I don’t know if this problem is exclusive to Citra or Qt apps as a whole, but changing my virtualSD paths into an NTFS partition on another drive, let’s say /media/ntfsOnDrive2/virtualSD/nand turns it into a different path like run/user/1000/doc/ee68dc4c/nand. So I had to change the path manually using the config file thanks to this doc: User Directory - Citra, it worked and all my installed games were shown on the menu. However, while it had supposedly loaded successfully, the game doesn’t run; no music, no graphics, even the FPS is 0. And I know that my install of Citra isn’t broken or anything because I’ve tried running .3ds files on an ext4 partition and it worked just fine.

System Information

  • Operating System: Linux KDE Plasma 5.27.5
  • CPU: Intel® Core™ i3-10100F CPU
  • GPU: NVIDIA GeForce GT 1030/PCIe/SSE2
  • Citra Version (found in title bar): 1919
  • Game: Any installed game on an NTFS partition
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (1.1 MB)

OK, I accidentally changed my nand path into run/user/1000/doc/ee68dc4c/nand for the example above and I pressed OK instead of cancel, but for some reason the games just worked. The sdmc path is still on NTFS though. The only problem is that I can’t save my game.

Are you still having this issue?

unfortunately, yes. do you have an idea on whats causing it? (build 1940)

Sadly, no. A bit outside of my knowledge. I can ask internally though.