Little black boxes

Let’s try setting up an older citra version. This version is what we would usually recommend for people with older iGPU’s that have driver bugs, but maybe it’ll help in your case as well. You never know.
Download citra-windows-mingw-20191214-ddb7ead.7z (direct link) from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392
Unpack it using winrar or 7zip. Put the unpacked folder anywhere you want. Inside the extracted nightly-mingw folder, create a folder called user. Now run citra-qt.exe from the folder and run your game.

Tried that a few months ago…

This specific version? with the user folder?

Something like it and it still did not fix the problem.

And I tried the suggestion you sent, and it did not fix it, at all.

Please upload a log file from that version.

citra_log.txt (84.4 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-1005G1 CPU @ 1.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            27.20.100.8853
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

citra_log.txt (129.6 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-1005G1 CPU @ 1.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            27.20.100.8853
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Are you sure you created the user folder like I instructed you to? It should try and load from that user folder if you created it instead of from roaming, which it’s doing right now.

Trying it again…

Nope, the little boxes are still showing up. And I did exactly what you asked

citra_log.txt (36.0 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-1005G1 CPU @ 1.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            27.20.100.8853
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

citra_log.txt (32.9 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-1005G1 CPU @ 1.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            27.20.100.8853
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

In which case I don’t. You can try redumping your game but I doubt it’ll have much effect.

In case you want to try anyways, make sure you have enough room on your SD-Card:
Dumping Game Cartridges
Dumping Installed Titles

I don’t think that would help much…

finally, i figured out what the problem was. I was missing a driver (.dll). I will post the link here. But that driver solved all the problems. I no longer see the artifacts and the game has not crashed, It looks good

1 Like

Awesome! Make sure to post this on the Github Issues page so they can see what the problem was and close the issue. If possible, add the exact name of the dll file that was missing!

Ah usually this means a Microsoft Visual C++ Redistributable package hasn’t been installed which includes that .dll file.

image